All systems are operational

Past Incidents

Sunday 3rd October 2021

No incidents reported

Saturday 2nd October 2021

No incidents reported

Friday 1st October 2021

Infrastructure Let's Encrypt root certificate expiration

A Let's Encrypt root certificate has expired yesterday. This can lead to various errors TLS error for old clients, the most common being "Certificate date is invalid".

Our Let's Encrypt certificates already provide the up-to-date Let's Encrypt chain but some older clients might not be able to trust that new chain because they don't have the new root Certificate Authority in their trustore. If you are in this situation with clients you can't update, we can sell certificates that will be trusted by those older clients. You can contact us on the support with the domains you need to protect.

You can also find more information about this expiration on Let's Encrypt website: https://letsencrypt.org/docs/dst-root-ca-x3-expiration-september-2021/

Thursday 30th September 2021

No incidents reported

Wednesday 29th September 2021

No incidents reported

Tuesday 28th September 2021

No incidents reported

Monday 27th September 2021

API Some API endpoints are returning high rates of HTTP 500 - Internal Server errors

Some API endpoints are returning high rates of HTTP 500 - Internal Server errors. We are investigating.

EDIT 14:57 UTC: A fix has been pushed, the errors should be resolved. We continue to monitor the situation.

EDIT 15:19 UTC: No more Internal server errors are happening, this incident is now closed.